Heartbleed

On 7th April 2014, researchers disclosed a previously unknown vulnerability in a technology called OpenSSL that powers encryption across most of the internet. The vulnerability is commonly known as the “OpenSSL Heartbleed Bug.”

Our IT team took immediate action to secure our site against this flaw. We closed any exposure that might have existed and now want to let you know that SpeckyFourEyes.com is not vulnerable to the Heartbleed bug.

In addition to this we also reissued our security certificate.

You can confirm this by looking at both test results at this website and this website (to be safe a site is required to pass both tests and run a safe version of OpenSSL, we run a safe version of OpenSSL as confirmed by the first site test).

As a precaution we advise our customers to change their passwords and as we have reissued our security certificate it is now safe to do so.

Comments are closed.